ねかつちう。

お金や節約に敏感な20代30代のための物欲系雑記ブログ

WD cloudでユーザーネームを変更したら、同期設定でフォルダを検出できないとか悲惨なことになってしまった

こんにちは、ちうぱんです。

悲惨なことになりました。

NAS関係の面倒なトラブルが発生。

結果的に失われたものは無いんですが、いろいろ大変だったので共有しておきます。

トラブルを起こしたのは、先日購入した「WD cloud」というNAS製品です。NASを使うのは初めてなんだけど、とにかく設定がラクで感動したのは既報のとおり。

www.nekatsu.com

ユーザーネームは変えるな。これは絶対だ!

さて、ここからが本題。

NASを含め、ネットワーク関係の不具合というのは、基本的に初期設定や設定変更のタイミングで発生しますよね。

今回のケースはまさにそれ。

まずは背景となった事象から説明しますね。

WD cloudでは、初期設定時に登録するユーザー名が、自動的にネットワーク名として設定されます(このことは設定が完了してから気づきました)。

設定項目が少なくてラクではあるんだけど、自分はいつもテキトーなユーザー名(hogehogeみたいな感じ)を設定してるんで、それがネットワーク名としてエクスプローラーとかに表示されるのは嫌なんですよ。

ユーザー名はWD cloudの設定画面に表示されるだけだけど、ネットワーク名は日常的に目に入るので、「hogehoge」みたいなのは気分的に嫌ですよね。

 

というわけで、、、

ちょっと迷ったんだけど、

ユーザー名とネットワーク名を変更した。

どちらもWD cloudの設定画面から簡単に変更できる。ネットワーク名の変更は、下の画像の赤枠部分を打ち直すだけ。

f:id:nekatsu:20170815122206p:plain

 

そしたら、、、

同期設定でフォルダが検出されない

という悲惨な状態になった (´Д⊂グスン

 

WD cloudには「WD sync」という同期機能があります。指定したローカルフォルダとNAS側のネットワークフォルダを自動で同期してくれる、dropboxのような便利機能です。この機能を目当てにWD cloudを購入する人も少なくないと思います。

問題が起きたのは、まさに「WD sync」

ユーザーネームやネットワーク名を変更すると、設定画面やエクスプローラーには正しく反映されるんですが、なぜだか「WD sync」にだけ反映されないんですよ。

ネットワーク名の変更が反映されないので、その下に保存しているフォルダも検出されないという致命的なトラブルに陥りました。

結果として、NAS側のネットワークフォルダが行方不明状態になってしまったため、「WD sync(自動同期機能)」が使えないわけですね。

 

まじか。

いやまじでこれ。

\(^o^)/オワタ

みたいな気分です、まじで。

お盆休みのマッタリ感がクールに吹き飛びました。

 

WD cloudの購入を検討している人、すでに使用している人、悪いことは言いません、安易にユーザー名やネットワーク名を変更しないことを推奨します。

とりあえず本体初期化で再設定。幸いにも失われたデータは無し。

いちおう解決方法をググってみましたが、参考になりそうな情報は見当たりませんでした。まだまだNASの普及率が低いということでしょう。

これはもう最終手段ですね。

初期化 (´;ω;`)ウッ…

WD cloudを初期化し、まっさらな状態から再設定しました。

幸いにもNAS内のデータはすべてローカル(Eドライブ)に同じものがあったので、失われたデータはありませんでした。

ちなみに、WD cloudの初期化方法は公式サポートを参照のこと。リンク先ページの「完全復元」の手順を実行してください。

https://support.wdc.com/knowledgebase/answer.aspx?ID=14473&lang=jp

初期化の手順はヒジョーに簡単ですが、データ使用領域が1/10程度でも、たっぷり3~4時間くらいはかかります。初期設定が数分で完了するのとは対照的なので驚きました。

あと、初期化の前にもう一つ試せばよかったなと思うのは、WD syncの再インストールですね。これは試してみる価値があると思います。

原因は不明。おそらく「WD sync」のソフト的なバグか?

結局のところ、今回のトラブルの原因は不明です。変えてはいけない設定を変えたわけではありませんし、WD sync以外は正常に動いていましたから。

推測でしかありませんが、WD syncのソフト的なバグなのかもしれません。

WD cloudは基本的にウェブ上で設定や操作が可能ですが、WD syncはPC用ソフトとして提供されています。このソフトとNASとの連携がうまくいっていない可能性はあると思います。

というわけで、いまひとつ釈然としないんですが、実被害は無かったということで、以上っ!